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About this document

About This Document
Welcome to the OPRO X Browser (OXB) User Guide. This document provides a detailed
description about the OXB and its usage, which is an application distributed with OPRO X
Server (OXS).
The target audience of this document is the end users who would be using the OPRO X
Browser to browse the Documents designed by the OPRO X Designer (OXD). The Template
Designers also use this application to preview Documents when creating Templates through
OPRO X Designer.
The conventions used in this document are simple to follow. The bold and italic words will
highlight a particular option and the topic would be discussed there in.
This guide has been broken down into various chapters for easy reading and quick
referencing, thereby making it easier for the user when reading through the document.
Microsoft and Windows are either registered trademark or trademarks of Microsoft
Corporation in the U.S.A. and other countries.
OPRO is a registered name of OPRO Japan Co., Ltd. All other names are registered
trademark or trademarks of their respective companies.

Date: December 2006
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1 Introduction, Installation & Un-installation
Introduction
OPRO X Browser (OXB) is an XML based application that is used to browse Documents
generated by OXS, which has an OPR or an OXR extension. With OXB, you can view, print
and also edit Documents. When the users of OXB request a report via the Internet, the file will
be downloaded and will be opened through OXB. OXB is a user-friendly application, which
allows the users access many features without being a competent user. Since OXB is a MDI
(Multiple Document Interface) application it can open maximum of 25 reports. OXB contains
the following special features.
Special Features of the OPRO X Browser
• Digital Signature Support - Digital Signature is a feature, which is used to verify
the authenticity of the Document generated through the OXS. OXB facilitates verifying a
Digital Signature attached to an OPR or an OXR Document.
• Document Security Support - OXB supports Document Security, which prevents
unauthorized copying and printing of the Document.
• Unicode Character Support – With the Unicode font support, the OXB user is
allowed to use any different font types as required. Therefore OPR or OXR Documents
containing far-eastern and Asian fonts can be viewed and printed via the OXB
application.
• End User Defined Character Support - With the End-User Defined Characters
(EUDC) support, if a Template is created through OPRO X Designer (OXD) that has
End-User defined characters it will be supported by OXB. OXD is a versatile Template
designing tool, which is used to design Templates for the Documents viewed through
OXB.
• eForm Submission - The eForm submission facility of OXB enables submission of
electronic forms as any other browser (Example Internet Explorer and Adobe PDF
Reader application).
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• OPRO XML Report (OXR) file format - OXR is a file extension, which is an
instance of XML encoded in UTF-8. It is just the decompressed version of OPR. An
OXR Document supports the entire characteristic of OPR Documents. OXB can
open/print OXR files and also it can contain any attachment files.
• OPRO Form Data (OFD) file format - OFD is a file extension, which is an instance
of XML encoded in UTF-8. This is mainly used to export form data to a separate OFD
file.
• VeriSign Digital Signature support - Signing of VeriSign Digital Signature is now
supported by OXB, which guarantees the security of the electronic Documents.
• Certificate Manager - Certificate Manager is a new administrative tool, which will
be used to manage digital certificates effectively in OXB.
• Verifying TimeStamp - The OXB supports TimeStamp verification. This feature helps
to guarantee that a document with a TimeStamp existed at a point-in-time and that its
contents have not changed since that time.
• Direct to Print facility - Direct to Print (DP) function will enable the user to send the
downloaded ODP file to the pre-specified printer without opening it in OXB.
• Vertical Text Display Capability – Vertical Text Display Capability allows
displaying any horizontal text line vertically, which is on a Label of an OXB Document.
Using the Vertical check box, the contents of the Label which are written in Japanese
text and full width characters (using font types MS Mincho, MS Gothic, MS PMincho,
MS UI Gothic) can be arranged in a vertical order from its current horizontal order, or
vice versa. The other font types would give rotated letters.
• Object Selection Function - The Object Selection function is another unique
feature provided by OXB. Some objects (objects such as Label, PageNumber and
DateTime) that are in the OPR or OXR Document can be selected individually with a
single mouse click upon the object.
• Displaying Total Page Number – The total page number will display the total
number of pages in an OPR/OXR Document. The behavior of displaying the total
page number will differ according the Document Template designed.
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Installation & Un-installation
Before installing OXB you need to check the system requirements.

1.1

Checking System Requirements
Before installing OXB, check the hardware and software requirements of your
computer. Completing a quick, successful installation depends on the local system
satisfying the software dependencies and space requirements for the software. This
section describes the hardware and software requirements for installing OXB. Verify
that the system meets the necessary requirements before starting the installation.
1.1.1 Hardware Requirements
OXB requires the following hardware:
Hardware
Requirements
CPU & Processor Intel Pentium II 233 MHz or higher
Memory
A minimum of 128 MB RAM is required.
Hard Disk Space A minimum of 30 MB hard disk space is required.
Table 1-1 Hardware Requirements

1.1.2 Software Requirements
OXB requires the following software:
Software
Operating
System

Requirements
Windows NT4.0 (Workstation / Server) (SP4 or
higher), Windows 2000(Professional/ Server) (SP1 or
higher), Windows XP, Windows 2003, Windows 98
and Windows Me.

XSL Transformer OXB uses MSXML for XSLT transformation. MSXML is
usually pre-installed in Windows desktops with Internet
Explorer. OXB supports msxml.dll, msxml2.dll,
msxml3.dll and msxml4.dll versions. For more
information please refer,
http://msdn.microsoft.com/library/default.asp?url=/lib
rary/en-us/xmlsdk/htm/sdk_installregister_4r76.asp
Table 1-2 Software Requirements
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Note
The performance of OXB will be reduced due to low resources in
Windows98 and Windows Me operating systems.

1.2

Installing OXB
If your machine satisfies the system requirements described in the previous
section you can start the OXB installation. Run setup.exe that comes with the OXB
installation. It is recommended to exit from all the applications before running the
OXB installation. Please note that the user should have the write permission to the
OXB installation folder.
Note
The following illustrations describe the step-by-step instruction provided during
the installation and the actual screens may vary according to your machine's
environment and OXB version you will install.

1.2.1 File Extracting Dialog

Figure 1.2.1: File Extracting Dialog

Wait until the setup extracts files to a temporary location (Windows Temp
directory) and displays the Welcome dialog.
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1.2.2 Welcome Dialog
When you get the Welcome dialog, click on the Next button to continue
with the OXB installation.

Figure 1.2.2: Welcome Dialog

1.2.3 License Agreement Dialog
This dialog shows the license agreement. In order to view the full license
agreement, use the Page Down key or the horizontal scroll bar. Click I
accept the terms in the license agreement, if you agree with the terms
in the license agreement. Thereafter click on the Next button to continue with
the OXB installation. The license agreement can be also printed through the
Print button.

Figure 1.2.3: License Agreement Dialog
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1.2.4 Customer Information Dialog
The setup automatically takes the customer information from the operating
system when they are available. You may edit this information if necessary
and click on the Next button to continue with the OXB installation. Anyone
who uses this computer (all users) option allows installing OXB for all
the users. Only for me option allows installing OXB application only for the
person who is currently logged into the computer and executing the OXB
installation.

Figure 1.2.4: Customer Information Dialog
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1.2.5 Destination Folder Dialog
Setup copies files by creating a folder OPRO and a sub folder OPRO X
Browser in your Program Files folder. This is the default installation path
for OXB. You may change the default location if necessary, by clicking on
theChange button.

Figure 1.2.5.1: Destination Folder Dialog

Figure 1.2.5.2: Change Current Destination Folder Dialog
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When changing the destination from the Change Current Destination
Folder dialog, you can select an existing folder from the Look in drop
down or type in the full path of the destination folder in the Folder name
text field. You can create a new folder through the New Folder button.
1.2.6 Ready to Install the Program Dialog
When the setup is ready to copy files into your machine, Ready to Install
the Program dialog displays the collected information. To change these
information click on the Back button. To install OXB, click on the Next
button.

Figure 1.2.6: Ready to Install the Program Dialog
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1.2.7 Installing OPRO X Browser Dialog
When the OXB installation is copying files, this dialog will display the
progress of copying the files to the specified destination folder. The Setup
Complete dialog will be displayed after copying all the files for the OXB
application.

Figure 1.2.7: Installing OPRO X Browser Dialog

1.2.8 Setup Complete Dialog
After completing the OXB installation successfully, you will get a
InstallShield Wizard Completed dialog. Please click on the Finish
button in order to complete and exit from the OXB installation.

Figure 1.2.8: Setup Complete Dialog
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Note
Sometimes you will be prompted to restart windows. It is
recommended that you restart the machine.

1.3 Uninstalling OXB
This section describes the procedure to uninstall OXB from your machine. You can
uninstall OXB through Add/Remove Programs option available in the Control
Panel.
Note
Before you uninstall OXB, make sure that you have closed the
OXB application.

1.3.1 Obtaining Windows Control Panel
To obtain Windows Control Panel proceed to the Windows Start menu
and click Start J Settings J Control Panel.

Figure 1.3.1 Selecting Windows Control Panel
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1.3.2 Selecting Add/Remove Programs Dialog
Double click on the Add/Remove Programs option available in the
Windows Control Panel to obtain the Add/Remove Programs dialog.

Figure 1.3.2 Selecting Add/Remove Programs Option
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1.3.3 Add/Remove Programs Dialog
The Add/Remove Programs dialog will be displayed which shows the
installed programs in your machine. Thereafter, select OPRO X Browser
from the program listing of the Add/Remove Programs dialog and click
on the Remove button.

Figure 1.3.3 Selecting the OPRO X Browser from the Listing and Clicking on the Remove Button

1.3.4 Add/Remove Programs Dialog Box

Add/Remove Programs dialog box will be displayed prompting for the
confirmation to delete files, which are in the folder where OXB has been
installed. Click on the Yes button to confirm deletion and proceed with the
OXB Un-installation process. Click on the No button to stop uninstalling OXB.

Figure 1.3.4 Add/Remove Programs Dialog Box
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1.3.5 Completing the OPRO X Browser Un-installation Process
After clicking on the Yes button on the Add/Remove Programs dialog
box, the OXB Un-installation process will begin automatically. Here a dialog
will be displayed, which shows the status of the OXB Un-installation process.

Figure 1.3. 5 OPRO X Browswer Un-installation Progress

Note
Sometimes when uninstalling OXB, the OXB Un-installation
process will prompt for the removal of .dll files through the
Remove Shared File? dialog. Click on the Yes button to
remove such files, which are in the folder where OXB has
been installed.
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2 Interface
OXB Main Menu

Application Toolbar

Side Tabs Panel

Document Toolbar

Document Window

Figure 2.1 The OXB Interface
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The interface of the OPRO X Browser consists of six main areas:
1. The OXB Main Menu
2. The Application Toolbar
3. The Document Toolbar
4. The Document Window
5. The Side Tabs Panel
6. The Document Preview Toolbar

2.1 The OXB Main Menu
The main menu contains all the commands, which represents all the functionalities
provided by the OXB.

Figure 2.1.1 The OXB Main Menu

The functionalities of the submenus are as follows.
•

File submenu - The options that consist in the File submenu relates to
opening, closing, saving and printing Documents via OXB, and also to
exit from the OXB application.

•

Edit submenu - Edit submenu will include options which are used to edit
Documents opened in OXB. Such options are Cut, Copy, Paste, Find,
Find Again and Select Graphic options. Find, Find Again and
Select Graphic functions are available only in the Print Preview
mode (Print Preview mode can be obtained through the Print
Preview option available in the File sub menu). The Edit menu will only
contain basic editing functions such as Cut, Copy and Paste when the
OPRO X Browser application is in the Browser mode.
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•

Document submenu - The Document submenu includes functions
related to the various aspects of the Document such as setting margins,
page navigation, digital signature verification, timestamp verification and
a quick view of the Document information.

•

View submenu – The View submenu contains various commands
concerned with the viewing of the opened Document in OXB.

•

Tools submenu – The Tools submenu contains various additional
features to support the Document and the browser.

•

Window submenu - The Window submenu contains various viewing
aspects within the browser window.

•

Help submenu – The Help menu consists of user help functions.

The functionalities of these submenus will be covered throughout this document.

2.2

The Application Toolbar

Figure 2.2.1 The Application Toolbar

The OPRO X Browser Application toolbar provides some of the essential commands
represented in the main menu. This provides a quicker access to such functions. The
commands which are in the Application toolbar consists Open Document, Save
As Document, Print Document, Print Preview, Margin, Save Margins,
Save Current Displayed, Certificate Manager, etc.

2.3

The Document Toolbar

Figure 2.3.1 The Document Toolbar

The OPRO X Browser Document toolbar provides essential commands needed for
the viewing of the Document. Each of the Document Windows opened within the
OXB has its own Document toolbar. These functions include view First Page, view
Next Page, view Previous Page, view Last Page, Page Zoom In and
Zoom Out, Percentage Zoom in facility, Fit in Window, Fit Width, Actual
Size, Side Tabs enable/disable button and the Stop button. Some of these
buttons will be activated and pressed down until the user represses the button to
undo that command.
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2.4

The Document Window
OXB is a MDI application. Therefore each Document is opened in a separate
Document Window. Each Document Window contains a separate Document
toolbar and a Side Tab panel.

Figure 2.4.1 The Document Window
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2.5

The Side Tabs Panel

Figure 2.5.1 The Side Tab Panel

The Side Tabs panel contains a Thumbnail tab, Attachments tab and a
Property tab.
The Thumbnail tab shows the Pages of a Document in a thumbnail form. This
allows the user to select the required page directly from the thumbnail panel without
viewing pages sequentially.
The Attachments tab displays the attached files of the Document.
The Property tab displays the properties of a selected component, where the
values can be changed as required. This supports for components such as Label,
URLLabel, AggregateFuntion, DateTime and PageNumber.
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2.6

The Document Preview Toolbar

Figure 2.6.1 The Document Preview Toolbar

The OPRO X Browser Document Preview toolbar will get activated when the
opened Document is in the Print Preview mode. Each of the Documents
opened within the OXB has its own respective Document Preview toolbar. The
functions which are included in the Document Preview toolbar contains view First
Page, view Next Page, view Previous Page, view Last Page, Page
Zoom In and Page Zoom Out, Percentage Zoom In facility, Fit in Window,
Fit Width, Actual Size, Side Tabs enable/disable button, view Document in
Grayscale and Monochrome, Find option and the Select Graphic option.
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• XP Visual Style
The new OPRO X Browser 2.5 supports XP Visual Style. All the Windows controls that
are included in the OPRO X Browser application (Buttons, Dropdown Menus, Edit
Boxes, Spinner Controls, etc) takes the appearance and the shape of Windows XP
based controls in a Windows XP environment.

Figure 2.2
Style Sheet Dialog in a Windows 2000 Enviornment

Figure 2.3
Style Sheet Dialog in a Windows XP Enviornment

This facilitates the OPRO X Browser user with the true Windows XP look and feel
experience.

Figure 2.4
Document toolbar of OXB in a Windows 2000 Enviornment

Figure 2.5
Document toolbar of OXB in a Windows XP Enviornment
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3 Menu Bar

Figure 3:1 OXB Main Menu

The menu bar consists of seven main options (File, Edit, Document, View, Tools, Window
and Help), and under each of these consists sub options relating to the each main option
listed. Most of the functions have special shortcut keys. They are listed in

Chapter 4.

3.1 File Menu
The options included in the File menu are shown bellow.

Figure 3.1.1: File Menu

The options, which consist in the File submenu relates to opening, closing, saving,
printing documents via OXB, and also to exit from the OXB application.
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•

Open:

Opens an existing Document that has .OPR, .OXR and
.OFD extension, in OXB. The OXB user can click on the
Open button ( ) on the Application toolbar, in order to
open an existing .OPR, .OXR and .OFD Document.

Document related tools

Figure 3.1.2: A Document has been Opened in OXB

•

Close:

•

Close All: Closes all the documents that are opened in OXB.

Closes an already opened Document in OXB.
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•

Save As: Saves an opened .OPR or .OXR Document. It can also
save an OPR file as an OXR. When saving a secure file
there are two methods. One method of saving an OPR file is
in the encrypted OXR form. The other is the decrypted OXR
format. When opening an OXR file, which is encrypted, it
will prompt to enter the password in order to open the file.
When opening a decrypted OXR file, there is no need to
enter a password, since it is a decrypted file and no security
is applied on the file.

•

Save Current Displayed: This option saves the Document as an
OXR file with current eForm data, added attachments and
changes done for Label, Date Time etc. Additionally, this will
create an XSL file where the changes are stored and saved
in the same folder where the OXR file was saved. When the
previously saved OXR file is opened, the corresponding
XSL style sheet file will be applied automatically.
Note
The Save Current Displayed option is disabled
initially. It is enabled only if the document is changed.

•

Print Preview: This option shows a preview of the Document before
it will be printed.
The Print Preview mode enables the user to view the
Document and get an idea of what the Document will look
like before it will be printed.
When the Print Preview button ( ) is pressed, the
browser window will be changed as shown in figure 3.1.3,
with lesser number of toolbars and menus, which mostly
involves preview related functions.

User’s Guide – OPRO X Browser

27

Chapter 3

Menu Bar

Figure 3.1.3: OXB in Preview Mode

There are additional toolbar buttons such as Grayscale
(
), Monochrome (
), Find (
) and Select
Graphic ( ) available when the Document is in the Print
Preview mode.
The Print Preview button ( ) in the Application toolbar is
used to obtain a preview of the Document. There is also an
option available in the File menu for previewing the
Document. In the Print Preview mode, the Print
Preview button ( ) will be pressed inward. To exit from
the Print Preview, click the Print Preview button ( )
again or click the Close button ( ) in the Document
Window.
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• Print Document: Prints the opened Document. The following dialog
box will be shown when the Print Document option is
selected from the File menu.

Figure 3.1.4: Print Document Dialog

A Document can be also printed with the default specified
printer by clicking on the Print Document button ( ) in
the Application toolbar. Here the Print Document dialog
box will not be displayed. If the user has changed the printer
settings using the Save Settings button on the Print
Document dialog, then the Document will be printed with
the modified printer settings.
In the Print Document dialog, the user is free to choose
the required printer. Information about the selected printer
will be displayed in the Printer Select area of the Print
Document dialog.
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After selecting the printer the user can change the properties
of the selected printer by clicking the Properties button.
The Additional button is an option in the Print
Document dialog box. This will give additional settings
when printing an opened Document. This is much more
useful when there are more than one layout with different
sizes and several pages to print in a Document. It also
facilitates the selection of a tray type for a particular printer.
2

4

6

1

10

7
3

5

8

9

Figure 3.1.5: Additional Settings

1 - Setting for printer model - When Setting for
printer model option is unchecked, additional settings
assigned will be applied to a printer, which is in a specified
network path. When Setting for printer model option is
checked, the additional settings assigned will be applied to
all the printers that have the same model name in the
network regardless of their physical network path.
2 - Template - This will display all the Templates belonging
to the opened Documents. For multi Template Documents, it
will display the names of the multiple Templates in an order.
3 - Wild card - This option is used to specify the same
additional settings for similar types of Templates. After
specifying settings and when saving with wild card, the
settings will apply for all the Templates which has the similar
Template name.
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Figure 3.1.6 Template Name with Wild Card

Template name with wild card window - This window
will be displayed when Use wild card… option is selected
from the Template dropdown of the Additional
Settings window. By clicking the OK button it will set the
Template of Additional Settings and close. If the input
value mismatches with the origional template name, it will
display a confrmation message.
4 - Layout - Lists all the Layouts of the Document.
5 - Feeder for 1st page - This will list all the available
paper trays for the specified printer, where the OXB user can
select paper tray type to print the first page.
6 - Feeder for other pages - This will list all the available
paper trays for the printer, where the OXB user can select
the paper tray type to print the other remaining pages of the
Document.
7 - Clear - This option will allow the OXB user to clear the
contents of the Additional Settings grid to the default
printer value.
The Clear button will be enabled when the contents of the
Additional Settings grid does not take default printer
values.
8 - Save - This option will save the selected additional
settings for the Document. The settings, which were saved,
will appear when opening the same Document again.
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9 - Close - This will close the Additional Settings grid.
10 - Extension - This option allows the OXB user to select
more printer properties other than selecting trays.
Note
To enable this option you have to obtain the necessary DLL
files from the OXS vendor.

1

3

4

2

5

6

Figure 3.1.7: Print Extension Module

1 - Printer - Displays the printer model name, which was
selected in Print Document window.
2 - Print Extension Name - This will indicate and assign
the name of the extended module.
3 - Properties - Displays the property setting window of
the printer Extension.
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Figure 3.1.8: Print Extension Name

4 - Description - Gives a detailed explanation of the
extended module indicated.
5 - OK - Makes the changes on the settings as permanent
and closes Print Extension Module dialog box.
6 - Cancel - Discards the changes made on the settings and
closes Print Extension Module dialog box.
The OXB user can specify the Page Range and number of
Copies to be printed in the Print Document dialog. The
printed Document can be obtained in Grayscale or
Monochrome colors apart from Normal.
Apart from these functions the OXB user can specify the print
range, where the user can choose to print only the odd
pages, even pages or all the pages in range. This function is
available at the bottom of the Print Document dialog box,
where there is a Print combo box (Refer figure 3.1.4).

Print to file function will write the contents of any valid
Document opened in OXB to a printer file with the
extension .PRN. If this function is enabled a Save As
dialog box will appear which will ask the user for the file
name and the location to save the printer file. Print to file
function can be enabled by checking the Print to file
check box in the Print Document dialog (Refer figure
3.1.4).
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Figure 3.1.9 Save As Dialog Box

The OXB user can save the printer settings as required using
the Save Settings button on the Print Document dialog.
When the user is trying to print the same Document again,
saved settings are loaded, as preferred by the user.
Note
Please note that these printer settings will be valid when
that particular Document (document which the settings
were made previously) is opened only on the same
computer where the settings have been saved.

This feature may be useful when the Direct to Print (DP)
function is used. Printer settings can be saved through the
Save Settings button in the Print Document dialog
(Refer figure 3.1.4). When the user has changed the printer
settings and saved those settings using the Save Settings
button, next time if he/she uses the DP function, that
particular document will be printed with the settings that
he/she previously saved.
If the user saves the printer settings with Current Page for
Print Range settings, in the DP mode, only the first page of
the Document will be printed.
The Collate check box becomes visible when the OXB user
selects to print more than one copy of the same Document. If
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the Collate check box is checked, it will print the pages of
requested copies separately in an order (Refer figure 3.1.4).
There is also a feature where the OXB user can print an
OXR file or an OPR file (without opening OXB), by
selecting the Print option available in the pop-up menu,
which is obtained through the right mouse button click on the
selected file. The selected file will be printed using the default
printer of the user’s computer. If the file has been saved with
specific printer settings using the Save Settings option,
then it will be printed using the saved printer settings.

Figure 3.1.10 File Print Option

An OXR or an OPR Document can be also printed with a
specific printer that has been installed in the OXB user’s
computer through dragging and dropping the required
Document into the Printers folder. This is shown clearly by
the following figure.
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Figure 3.1.11 Dragging and Dropping File into the Printers Folder

Custom Page Printing: When printing custom size paper,
please set the paper to the direction, which the printer
supports. If the direction and custom size differ, OXB output
may differ. For the printable directions, please refer the
printer manual.
Exit: The Exit option in the File menu will terminate the
OPRO X Browser application.
Note
During the Print Preview mode the user can exit from
the OXB application by clicking the Close ( ) button of
the OXB application window.
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3.2 Edit Menu
The options included in the Edit menu are shown bellow.

Figure 3.2.1: Edit Menu

Edit menu will include options to edit Documents opened in the OXB. Such
options are Cut, Copy, Paste, Find, Find Again and Select Graphic
options. Find, Find Again and Select Graphic functions are available
only in the Print Preview mode. The Edit menu will only contain basic
editing functions such as Cut, Copy and Paste when OXB is in the
Browser mode.
•

Cut:

The selected text will be removed from the component and it
will be placed in the Windows Clipboard.

•

Copy:

The selected text will remain in the component and a
duplicate instance of it will be placed in the Windows
Clipboard.

•

Paste:

The text, which is in the Windows Clipboard, can be pasted
to the Value property of each component, which is on the
Property Sheet of the Side Tabs Panel.

•

Find:

Helps to find the required text in the document (This function
is available only when the document is in the Print
Preview mode). You can perform the Find function by
clicking on the Find button (
Preview toolbar.
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Figure 3.2.2: Find Text Dialog Box

•

Find Again: Helps to find the previously searched text again (This
function is available only when the document is in the Print
Preview mode).

•

Select Graphic: Allows selecting a part of the Document as a graphic,
which can be later copied to the clipboard using the popup
menu. The popup menu is available by right clicking on the
Document area. (This function is available only when the
Document is in the Print Preview mode). You can perform
the Select Graphic function by clicking on the Select

Graphic button (
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3.3 Document Menu
The options included in the Document menu are shown below.

Figure 3.3.1: Document Menu

The Document menu includes functions related to various aspects of the
Document such as margin settings, page navigation, digital signature
verification, timestamp verification and a quick view of Document information.
•

Margin:

Shows margins in the Document. The user can set the
margins as required. The margins, which were set by the
OXB user, are only valid for that particular Document, which
is opened on the computer where the margins have been set.
The margins can be set from all four sides of the Document
by dragging the margin limit tabs. The following figure shows
a Document that shows the margins. You can view the
margins of the Document by clicking on the Margin button
(
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Margins

Figure 3.3.2: Document Margins in OXB

Double clicking on the horizontal or the vertical ruler,
displays the Set Margin values dialog box (Refer figure
3.3.3), which allows you to set margins in terms of
centimeters.
•

Save Margin: Saves the margin values assigned in the Show
Margin option for the selected Document. You can save
margins of the Document by clicking on the Save Margin
button ( ) available in the Application toolbar.
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•

Set Margin: Allows the user to set margin values with the use of Set
Margin dialog shown in figure 3.3.3.
o Reset: Allows user to apply the previously saved margin
values.
o Save: Saves the modified margin values and applies
these changes to the currently opened Document.
o Apply: Applies the modified margin values to the
currently opened Document.

Figure 3.3.3: Margins in a Document Opened in OXB

• Verify Digital Signature: If the digital signature component exists,
OXB will verify the signature. The digital signature
component allows the creator of the Document to
authenticate the Document to the user by adding a unique
signature into the Document. This is done at the creation of
the Document. If the Document is modified in anyway after it
has been created, the signature will be invalid. There are
two other instances where the Document could not be
guaranteed. That would be when the digital signature has
not been activated or when the signature has expired its
valid term. After verifying the Digital Signature, the Digital
Signature Properties dialog will be displayed where
there are two tabs, namely Signature Properties Tab
and Certificate Attributes Tab.
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Signature Properties tab: The Signature Properties
tab will show general details such as;
o The person who signed the Document.
o The time, which the Document was actually signed
by the OPRO X Server.
o The contact information of the Document creator.
Authentication (Green or Red)

Figure 3.3.4: Digital Signature Properties (Signature Properties Tab) Dialog
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Certificate Attributes tab: The Certificate Attributes
tab will show the information with regard to the certificate.
These details contains the certificate Name, the Serial
Number of the certificate, the Digital Signature validity time
frame in GMT and other details regarding the certificates
such as the algorithm used, the fingerprints of the certificate,
the user name and the issuer’s name.

Figure 3.3.5: Digital Signature Properties (Certificate Attributes Tab) Dialog

When Direct to Print function is used the Digital Signature
will be automatically validated before the document will be
printed. If the Document is valid a verified (√) mark will be
printed on the Digital Signature component of the printed
document or if the Document is invalid a cross (X) mark will
be printed on the Digital Signature component of the printed
Document.
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•

Verify Time Stamp Token
There are many possibilities of verifying a Time Stamp Token.
They are;
1. To verify the digital TimeStamp, which exists in the
Document.
2. To verify the authenticity of an attached file in the
Document, by verifying the time stamp token file which has
the corresponding name and the extension of the attached
file. Example attached file - OPRO.txt and the token file
will be OPRO.txt.tst.
3. To verify the authenticity of an external file which exists in
the hard drive of the user, by dragging the corresponding
time stamp token file into the OPRO X Browser application.
Example external file - External.txt and the corresponding
time stamp token file will be External.txt.tst.
The TimeStamp component is used to provide verification
and content authenticity of the Document being generated
by the OPRO X Server. The TimeStamp component
provides a time-stamp, which is essential to guarantee that
the Document existed at a point-in-time and that; the contents
have not changed since that time. If the Document is
modified in anyway after it has been created, the
TimeStamp will be invalid. There are two other instances
where the Document could not be guaranteed upon, that
would be when the TimeStamp has not been activated or
when the TimeStamp has expired it’s valid term.
TimeStamp Detail dialog will consist of two tabs, namely the
Tab and the TAC

Time Stamp Information
Information Tab.
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Time Stamp Information Tab: The Time Stamp
Information Tab will display details such as Time Validity
information (TimeStamp status, TimeStamp generation time,
target file, etc.) and TimeStamp Token information (Version,
TSA Policy, Hash Value, Hash Algorithm, etc.)
Authentication (Green or Red)

Figure 3.3.6: TimeStamp Detail Dialog (Time Stamp Information Tab)

View TSA Certificate - The View TSA Certificate
button is used to view the certificate information in a
separate Windows Certificate applet.
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TAC Information Tab: The TAC information Tab will
display details such as Certificate Information (Version of the
Time Audit Certificate, Serial Number of the Time Audit
Certificate, Period of Validity, etc.), Publisher information,
Information of the Signature (The hash algorithm name, The
hash algorithm identifier, Length of the hash data, etc.),
Information of time audit (The offset value in seconds, The
network delay in seconds, etc.) and the Information of the time
audit policy (The offset value in seconds, The network delay in
seconds, etc.).

Figure 3.3.7: TimeStamp Detail Dialog (TAC Information tab)
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•

First Page: Takes the OXB user to the first page of the multi-paged
Document. You can also go to the first page of the document
by clicking the First Page button ( ) on the Document
toolbar.

•

Previous Page: Takes the OXB user to the previous page of the multipaged Document. You can also go to the previous page of
the document by clicking the Previous Page button ( ) on
the Document toolbar.

•

Next Page: Takes the OXB user to the next page of the multi-paged
Document. You can also go to the next page of the
Document by clicking the Next Page button ( ) on the
Document toolbar.

•

Last Page: Takes the OXB user to the last page of the multi-paged
Document. You can also go to the last page of the document
by clicking the Last Page button ( ) on the Document
toolbar.

•

Insert Attachment: This option will insert attachments to the
Documents. Attachments can be also inserted by clicking on
the Insert Attachment button ( ) on the Attachment
toolbar.

Note

Insert Attachment option will be disabled when a
secured document has been opened.
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•

Document Information: Shows details pertaining to the Document.

Figure 3.3.8: Document Information dialog box

•

Reload: This is helpful when retrieving the original Document after
doing some modifications to it. Alternately pressing the F5
key can reload the currently opened Document.
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3.4 View Menu
The options included in the View menu are shown bellow.

Figure 3.4.1: View Menu

Contains various commands concerned with the viewing of the Document.
•

Toolbar: Allows adding or removing the Application toolbar in OXB.
If enabled, the OXB will show the Application toolbar.

•

Status Bar: Allows adding or removing the Application status bar &
the Document status bar from the application and from the
child frame.

•

Zoom:

This option allows the user to have a custom zoom into the
Document using the Zoom dialog box as shown below.
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Figure 3.4.2: Zoom Dialog Box

•

Zoom In: Allows zooming into the Document. You can also perform
the Zoom In function by clicking on the Zoom In button
( ) available in the Document Preview toolbar.

•

Zoom Out: Allows zooming out of the Document. You can also
perform the Zoom Out function by clicking on the Zoom
Out button ( ) available in the Document Preview toolbar.

•

Fit in Window: Zooms the Document in order to fit in the window of
the browser. You can also perform the Fit in Window
function by clicking on the Fit in Window button ( )
available in the Document Preview toolbar.

•

Fit Width: Zooms the Document to the width of the browser window.
You can also perform the Fit Width function by clicking on
the Fit Width button ( ) available in the Document Preview
toolbar.

•

Actual Size: Zooms the Document to its actual size. You can also
perform the Actual Size function by clicking on the Actual
Size button ( ) available in the Document Preview toolbar.

•

Grayscale: Converts the Document color to Grayscale. This
functionality is available in Print Preview mode only. With
the Grayscale button ( ) on the Preview toolbar, this
functionality can be also performed. The Grayscale icon
( ) will be displayed on the bottom right hand corner of the
browser window, when the Document is viewed in
Grayscale.
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•

Monochrome: Converts the Document color to Monochrome (Black
and White color). This functionality is available in the Print
Preview mode only. With the Monochrome button ( )
on the Document Preview toolbar, this functionality can be
also performed. Then the Monochrome indication icon
( ) will be displayed on bottom right corner of the browser
window.

•

Side Tabs: This consists of the Thumbnail tab, the Attachments tab
and the Property tab. The Thumbnail tab displays the
pages of the Document as thumbnails. Each page can be
selected by clicking on the thumbnail of the required page.
Attachments tab displays the attached files of the currently
opened Document. Property tab displays the properties of
a selected component, where the user can change its values
as required. Properties cannot be changed for all the
components. Clicking the Side Tabs button ( ) on the
Document toolbar can enable/disable side Tabs in OXB.
o Thumbnail tab:

Figure 3.4.3: Thumbnail Tab

All the pages of the Document will be shown as thumbnails.
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o Property tab:

Figure 3.4.4: Property Tab

The Property tab helps to set run-time property changes for
components in the Document. Basically the property values
of the component can be edited or changed in the
Document. Only the properties of the Label, URLLabel,
Page Number, Date Time and the Aggregate
Function of the OPRO X Designer (OXD) can be changed.
General Property:
Specifies the name to identify and describes the size,
location and the appearance of the component.
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Font Property:
With this property, the fonts and font styles of the selected
component can be changed. This includes the font name,
size, color as well as font styles like Strikeout, Underline,
Bold and Italic.
Custom Property:
With this property, the OXB user can change the layout (i.e.
position of the text in the frame) of the selected component’s
background color, text style such as Autosize & Equalize
as well as text appearance like Line Interval, Character
Interval and Tab Size.
Data Property:
With this property, the OXB user can change the Caption
of the selected component.
o Attachments tab:

Figure 3.4.5: Attachments Tab

The Attachments tab helps to display and to administer all
the attached files in a particular Document. It helps to
conduct functionalities like Insert Attachment, Open
Attachment, Verify Time Stamp Token, Save
Attachment, Save All Attachments, Delete
Attachment and Delete All Attachments. The
Attachment toolbar also contains other buttons to handle
attachments to the given Documents such as;
o Open Attachment - Opens an attachment, which
exists in the Attachments tab. By clicking Open
Attachment button ( ) on the Attachment toolbar, the
OXB user can open an attachment.
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o Verify TimeStamp Token - The Verify TimeStamp
Token option allows verifying a timestamp token file (TST
file), which is attached to the Document. By clicking

Verify TimeStamp Token button (

) on the
Attachment toolbar, the OXB user can verify a timestamp
token file (TST file).
o Save Attachment - Saves an attachment in the
OXB user’s computer. By clicking Save Attachment
button ( ) on the Attachment toolbar, the OXB user can
save an attachment.
o Save All Attachments - Saves all the attachments
in the Attachments tab into the OXB user’s computer.
By clicking Save All Attachments button ( ) on the
Attachment toolbar, the OXB user can save all the
attachments.
o Delete Attachment - Deletes selected attachments
from the Attachments tab. By clicking Delete
Attachment button ( ) on the Attachment toolbar, the
OXB user can delete any selected attachment.
o Delete All Attachments - Deletes all the
attachments from the Attachments tab. By clicking
Delete All Attachment button ( ) on the Attachment
toolbar, the OXB user can delete all the attachments.
•

Source:

•

Full screen: The Full Screen function gives a full screen view of the
Document opened in OXB. This is similar to the figure shown
below. To close Full Screen mode click on Close Full
Screen button, which is at the top right hand corner of the
screen. When the Document is in Full Screen mode, the
Full Screen Control Bar contains the main menu of OXB
and the Document toolbar. The Full Screen Control Bar
displays at the top of the screen when the cursor is brought
to the top of the screen.

Allows viewing the source of the Document in a text editor.
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Full Screen Control Bar

Close Full Screen
button

Figure 3.4.6: Document in Full Screen Mode (Without Thumbnail view)

If the Thumbnail tab is enabled the Thumbnail tab is also
activated in the Full Screen mode.
Thumbnail view enabled in Full Screen mode

Figure 3.4.7: Document in Full Screen Mode (With Thumbnail view)
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3.5 Tools Menu

The options included in the Tools menu are as shown bellow.

Figure 3.5.1: Tools Menu

Tools menu contains various additional features to support the document and the
browser.
Options: When selecting the Options from the Tools menu, the Options
dialog will be displayed. The Options dialog consists of two tabs, namely
General tab and the Browser Theme tab.

Figure 3.5.2 : Options Dialog Box
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General Tab: Allows setting various advanced features such as;
•

Internet Connection

– This option is used to bring up the
Internet Options dialog box in order to set the proxy
address and the port used by the proxy server. Proxy
addresses, which contain SSL support, can also be assigned
as the Proxy address for OXB. The Internet Options
dialog box can be called by clicking on the Settings button
available in the Options dialog.
In order to setup a proxy server for Internet Explorer please
visit;
http://support.microsoft.com/default.aspx?scid=kb;enus;135982

Figure 3.5.3 : Windows Internet Options Dialog Box
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•

Error Log – Allows activating the error log for OXB and specifying the
maximum size of the error log.
o Activate Error Log: The Activate Error Log option
allows creating a log file when this option has been clicked.
The name of the error log file is OXBError_log.txt and it
is created in the user profile. This will be important when
using Direct to Print (DP), since when an error occurs, it
will be logged in the log file.
o No of Error Lines: Allows selecting the number of error
lines in the log file. When it exceeds the limit, it will overwrite
from the beginning.

•

Delete document when closed– This option allows to determine
whether to delete the source Document from the cache and
stored places for security reasons. If this option is enabled,
the user will be prompted each time whether to delete the
Document or not, when closing the Document.

•

Delete document after direct print – This option allows to
enable/disable the facility of deleting the Document after it
has been printed via the Direct to Print facility. Only the
Documents, which have the .ODP extension, will be deleted
from its current storage location after it has been printed
through the Direct to Print facility.

•

Server Message – This option allows the server messages to be
displayed in OXB.

•

Web Browser – The Web Browser option helps to select whether
the document should be opened in OXB or in Internet
Explorer as a plug-in.

•

Viewer for View Source – Enables the user to select a text editor to
view the source XML file.
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Browser Theme Tab: This allows changing the outlook of OXB. Various aspects
of the browser can be changed, such as the Document Window Background
Color, Thumbnail Panel Background Color, Toolbar Background
Image, Browser Font type, size and color. The user can load any bitmap type
image as the Toolbar background Image. These user options can be changed
and also saved as a theme under the Themes section at the bottom of the dialog,
where the Save As option is given. The Apply button is used to apply the selected
theme from the Themes dropdown.

Figure 3.5.4: Changing Browser Theme
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When the Edit Button of the Toolbar Background
Image section is clicked, the Skin Editor dialog will be
displayed.

Figure 3.5.5: Selecting the Skin and the Skin Editor
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The Skin Editor dialog allows the OXB user to
create/modify/load an image that will be used as the skin
for OXB. The various RGB (Red, Green, Blue) levels can be
set using the three given track bars. Clicking the Merge
Random Color button can change the colors randomly.
An example result is shown below:

Figure 3.5.6 : Changing Skin Color
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The Test button allows previewing the desired image
created with the necessary colors. The preview will be
displayed as follows.

Figure 3.5.7: Previewing the Skins

When you press the OK Button, you will go back to the
Options dialog. Next press the OK button of the Options
dialog in order to apply the selected image as the browser
skin.
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•

Style Sheet: Helps to apply various styles to the Document using style
sheets. The style sheets can be developed by any user with
the knowledge of XSL and the structure of the .OPR File
format. Some sample XSL style sheets are given with the OXB
and they are available in the sub directory called Style
Sheets in the Applications Directory.

Figure 3.5.8: Selecting a Style Sheet

Before applying a style sheet you will need to add a style
sheet using the Add button and then you will be able to see
the added style sheets in the Select the Style Sheet drop
down list. Select the style sheet you desire from the list and
click on the OK button to apply the style to the document.
Any style sheet added to the Select the Style Sheet drop
down list can be removed. To remove a style sheet, select
the style sheet you want to remove from the Remove Style
Sheet drop down list and then click on the Remove
button.
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The four default style sheets that have been given are as
follows:
Style1: Changes the background color of all the
Labels in the Document to Gray color.
Style2: Changes the font color of all the labels in the
Document to Blue color.
Style3: Changes the Frame of all the Labels (if visible)
to Red color.
Style4: Does all the above to the Document.

C:\Programme
Files\OPRO\OPRO X Browser\style sheets\ (If you
These

files

are

located

at;

have installed the OPRO X Browser in the default installation
path).
•

Certificate Manager: Certificate Manager will display Digital
Certificates. With the Certificate Manager, the OXB user can
Add, Remove or View certificates in Personal, Intermediate
CA or in the Trusted Root CA.

Figure 3.5.9: Certificate Manager
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Window Menu

The options, which are included in the Window menu, are described bellow.

Figure 3.6.1 Window Menu

The Window menu contains various viewing aspects within the browser
window.
•

Cascade: Cascades all the Document Windows that are opened in
OXB.

•

Tile Horizontally: Horizontally Tiles all the Document Windows that
are opened in OXB.

•

Tile Vertically: Vertically Tiles all the Document Windows that are
opened in OXB.

•

Minimize All: Minimizes all the opened Document Windows in OXB.

•

Arrange All: Arranges all the minimized Document Windows in OXB.

•

Maximize: Maximizes the currently active Document Window in OXB.

•

The Window menu also lists currently opened documents in OXB.
When the user selects a file from this list, the selected file will be brought
to front.
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3.7 Help Menu

The options included in the Help menu are as shown bellow.

Figure 3.7.1: Help Menu

The Help menu consists of user help functions.
•

Contents & Index: Allows the user to access the online help of the
OPRO X Browser application.

•

Quick Help: Helps to display a pop up screen or the relative help
page, which describes the functionality of the pointed item,
through the mouse cursor. When this option has been
selected the mouse cursor changes to an arrow with a
question mark next to it ( ).

•

About:

Displays version and copyright information relating to the
OPRO X Browser application.
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4 Shortcut Keys
* Menu option visible in the Preview Mode, but invisible in the Browser Mode.
** Menu option invisible in the Preview Mode, but visible in the Browser Mode.
Main Menu

Sub Menu / Function

Shortcut Key

File

Open

Ctrl + O

Close **

Ctrl + F4

Close All **

------

Save As

Ctrl + S

Save Current Displayed

Shift + Ctrl + S

Print Preview

Ctrl + F2

Print Document ...

Ctrl + P

Cut

Ctrl + X

Copy

Ctrl + C

Paste

Ctrl + V

Find…*

Ctrl + F

Find Again*

F3

Select Graphic*

------

Margin

-----

Save Margin

-----

Set Margin...

-----

Verify Digital Signature

-----

Verify TimeStamp

-----

First Page

Ctrl + Home

Previous Page

Ctrl + PgUp

Next Page

Ctrl + PgDn

Last Page

Ctrl + End

Insert Attachment ...

Ctrl + I

Document Information ...

Ctrl + D

Reload

F5

Edit

Document
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View

Tools

Window

Help

Toolbar

-----

Status Bar

-----

Zoom ...

-----

Zoom In

Num +

Zoom Out

Num –

Fit in Window

Ctrl + 0

Fit Width

Ctrl + 1

Actual Size

Ctrl + 2

Grayscale *

Ctrl + G

Monocrome *

Ctrl + M

Side Tabs

Ctrl + T

Source

Ctrl + U

Full Screen

F11

Options ...

Ctrl + E

Stylesheet ...

----

Certificate Manager ...

----

Cascade

----

Tile Horizontally

----

Tile Vertically

----

Minimize All

----

Arrange All

----

Maximize

----

Contents and Index

F1

Quick Help

----

About ...

----
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Acronyms
DP

Direct To Print

HTML

Hyper Text Markup Language

ODP

OPRO Direct to Print

OFD

OPRO Form Data

OPR

OPRO Print Report

OXB

OPRO X Browser

OXD

OPRO X Designer

OXR

OPRO XML Report

OXS

OPRO X Server
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